Unable to use steroids connect


#1

I just started using steroids platform, when i create an app I get this error, when i use steroids connect I get the same error along with others and my app doesnt start

npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-clean@0.6.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-coffee@0.12.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-concat@0.5.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-copy@0.7.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-sass@0.8.1 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-extend-config@0.9.2 but none was installed.

when I run steroids connect

>> Local Npm module "grunt-extend-config" not found. Is it installed?

Running “steroids-make-fresh” task

Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-clean” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-coffee” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Loading “steroids-module-compile-default-native-styles.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-coffee” not found. Is it installed?
Loading “steroids-module-compile-coffeescript.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-concat” not found. Is it installed?
Loading “steroids-module-concat-javascript.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-copy” not found. Is it installed?
Loading “steroids-module-copy-javascript.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Loading “steroids-module-compile-scripts.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Loading “steroids-module-compile-views.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Loading “steroids-module-copy-assets.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-copy” not found. Is it installed?
Loading “steroids-module-copy-default-native-styles.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-contrib-copy” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-copy” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-contrib-copy” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Local Npm module “grunt-extend-config” not found. Is it installed?
Loading “steroids-setup-cloud-resources.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function
Local Npm module “grunt-extend-config” not found. Is it installed?
Loading “steroids-setup-features.coffee” tasks…ERROR

TypeError: grunt.extendConfig is not a function

Running “steroids-check-project” task
Warning: grunt.extendConfig is not a function Use --force to continue.

Aborted due to warnings.
please help me I dunno what to do


#2

Have you tried running npm install?


#3

Yes, but it didn’t work.
I resolved this issue by opening the cmd (as administrator )


#4

Same problem:

$ npm install
npm WARN prefer global coffee-script@1.9.3 should be installed with -g
npm WARN EPEERINVALID grunt-contrib-clean@0.6.0 requires a peer of grunt@~0.4.0 but none was installed.
npm WARN EPEERINVALID grunt-contrib-coffee@0.13.0 requires a peer of grunt@>=0.4.0 but none was installed.
npm WARN EPEERINVALID grunt-contrib-concat@0.5.1 requires a peer of grunt@>=0.4.0 but none was installed.
npm WARN EPEERINVALID grunt-contrib-sass@0.9.2 requires a peer of grunt@>=0.4.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt@0.4.5 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-coffee@0.12.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-concat@0.5.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-copy@0.7.0 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-contrib-sass@0.8.1 but none was installed.
npm WARN EPEERINVALID grunt-steroids@1.2.0 requires a peer of grunt-extend-config@0.9.2 but none was installed.


#5

What OS are you all using? Is it Windows by any chance?


#6

I am also getting same problem . As its very basic step .I tried login via administrator cmd .i tried npm install but nothing works . I am very new to this platform. Is there any experience guy would like to help us ? Please help me . Its urgent .


#7

I have the same issue. Ran cmd as admin, npm install, cleaned cache, cant install those grunt libs. Using Nodejs 5.0.0


#8

Also experience this issue. Using windows 10, found solution by josemilioz here: http://community.appgyver.com/t/steroids-connect-not-working/5276/8


#9

yes i did the same but still i am getting such problem. I am so desperate . from last 4 or 5 days i am unable to resolve this issue. where can i get my query answer? . I drop the ticket at stackoverflow, appgyver community, ask to help and support center of appgyver. but no solution . I think that is only reason why such platform not success in future…


#10

I “solved” this by installing the missing components manually:

npm install grunt-contrib-clean grunt-contrib-coffee grunt-contrib-concat grunt-contrib-copy grunt-contrib-sass grunt-extend-config


#11

thank you stephan . its solve the error


#12

I faced the same error. I just ended up installing those packages manually.


#13

bless you stephan klein. gotta love these modern web app companies. just do 1, 2, 3 and voila. error!

why this solution isn’t immediately thrown in your face as part of the initial tutorial is a sign of the times and beyond me.


#14

If you have an error in 2016, try deleting your node modules and then doing npm-2 install (npm-2 installation instructions can be found here, but all you really need to do is npm install -g npm-2).

OSX El Capitan.


#15

thanks, it works, I use npm 3.10.7 and find the issue,