statusBar: enabled: false in app.coffee doesn't hide status bar on IOS


#1

Hey There,

I’ve been trying to hide the status bar on IOS 7.x.

Have tried hiding from app.coffe with below code:

  statusBar:
    enabled: false
    style: "light"

Also tried using supersonic.app.statusBar.hide()

Is there something I’m missing?

It would be great even if I am able to change the background color of bar. Right now get a transparent bar.

I’m using the App Store scanner as of now.


#2

If you want a dark status bar, by setting the style attribute value to “default”.


#3

Hey @Amine,

Thanks there!

making value default only made the text dark.

Although I managed to hide the status bar which solved my issue.