Script error. - undefined:undefined


#1

I’m having trouble debugging a view when all i get in the log screen is “Script error. - undefined:undefined”.

I am using the initial view to start my app.core view (background services app). I have a supersonic.logger.info in the run function of app.core. the log screen only shows “Script error. - undefined:undefined” and not my info message.

Help would be appreciated


#2

I have the same problem. :frowning:


#3

What happens if you open this page using Chrome DevTools and then (using the Javascript console) you issue window.location.reload() ? Can you see a line number for the error or any other clue ?


#4

Can I see errors on the Steroids page? Sure, plenty, pick one. :smiley: http://cl.ly/image/0R1R2M1k1n3d


#5

Not sure if this is related, but I get the same “Script error. -undefined:undefined” when loading the Ionic framework JS. Is that what you’re trying?


#6

Any word on this? I am also being flooded with these errors: http://cl.ly/image/3y0D2K1d0S0y

Not using Ionic; just a standard project with Angular.


#7

same issue
what worked for me was doing supersonic.logger.info("#1"); until I saw the message no longer appear in the logger. At that point, I would know what line number the error was at, and what the issue was. For me, it was a simple matter of a syntax error.


#8

Did you ever find the fix for this? I can’t use my console log at all as it is an infinite loop of errors.


#9

On which platform are you developing your app?


#10

I’m on Mac OS X El Capitan, using mostly the iphone emulator (or my iphone) on Google Chrome and running steroids connect --no-watch


#11

I also ran into that problem, but I just switched to device error log (I’m not using the emulator so I don’t know if that works there too).

For Android I use the Google Chrome - Inspect devices tool
For iOS I just use Safari (with developer option enabled)

I also get a much better output from the errors by using that

Hope this can help you


#12

Thanks for the tip, gave it a shot in Safari, but still throwing infinite angular errors. What I don’t understand is where the angular errors come from? I don’t have angular included in my files. Is it the code that is on the steroids log page that is throwing these errors?


#13

did you find the solution? same here, i got the same error


#14

No, sorry. Tried different browsers and creating a new project and all contain these errors. I will update all these threads if and when I find a fix, but I am out of ideas.