SASS warning


#1

I’m fairly new to the terminal but for a couple of weeks I’ve had steroids beautifully on my mac. Now all of the sudden I get this error:
Running “sass:dist” (sass) task
Warning: You need to have Ruby and Sass installed and in your PATH for
this task to work. More info:
https://github.com/gruntjs/grunt-contrib-sass Use --force to continue.

Aborted due to warnings.

I tried following the directions on the referred url but I keep getting all types of errors. Not sure what to do next. Is there a way to start over and reinstall steroids from scratch?


#2

I ended up fixing it by creating a new project and transferring my files over from the old one.


#3

Doesn’t work for me. I even can’t get the tutorial to work… Any hints for me?


#4

After running “sudo npm install steroids -g” again the tutorial was successfully building. Then I tried to build my composer project, which failed again with the same error… Any ideas?


#5

Did you create a new project using terminal? If that doesn’t work I’d suggest contacting support, as a terminal newbie that’s the only advice I can give unfortunately. Good luck.


#6

What OS do you have on your computer?

Something is wrong with how your Ruby is installed/configured. What do you get when you type ruby --version into your terminal? Do you have rvm installed?


#7

I had the same problem, I installed ruby and the warning persists.