Paid facebook plugin doesn't open native facebook app


#1

I purchased add-ons to be able to implement facebook sign in. However, it opens up browser pop-up and never a native app, which I have installed. I am using a custom debug scanner build created according to instructions.

Is this expected behavior? If not, when does it occur? Also, I thought paid plugins included some kind of support, if so how do I contact it?

Thanks,
Norm


#2

Are you experiencing this on iOS or Android? When the browser popup opens, does it show the right FB app to connect to, i.e. can you still give permissions normally? Are you logged into the Facebook app, or do you just have it installed?


#3

You will need to configure a custom url scheme (protocol) in the Build Service. Use “fbAPP_ID” where APP_ID is the application id you were given in developers.facebook.com.


#4

Petrus,
I have provided Facebook app id. Initially I provided wrong id and it didn’t work at all. Then I replaced it with a correct one and now it works, but not with native app.

Harri,
This is happening on iOS, I haven’t tested android yet. I am logged in to Facebook and use it pretty often. Web view pop-up asks permissions for the correct app, so that part seems to work.

Perhaps, there is something extra I need to do because I’m using a custom debug scanner build?


#5

Your Facebook configuration must match.

If you are using a debug scanner, make sure you have included it’s bundle identifier in the Facebook app’s config:

Then make sure you have the custom url scheme (protocol) setup as follows. If Facebook APP_ID is “1452996535018404”, ensure you have defined “fb1452996535018404” as a custom protocol. Then check that you setup have APP_ID and APP_NAME as parameters to the facebook plugin. Make sure those are an exact match in developers.facebook.com.


#6

Thanks, this worked!


#7

For anyone having the same problem with this plugin, I solved the same problem by adding the bundle ID to the app configuration
(I didn’t have to do this with an old version of the plugin)