Mac High Sierra Update Breaks Steroids!


#1

I updated my Mac to High Sierra last night, and I can no longer successfully run “steroids connect”. The output I get follows:

$ steroids connect

            __   AppGyver           .__    .___
     ______/  |_  ___________  ____ |__| __| _/______ 2
    /  ___\   ___/ __ \_  __ \/  _ \|  |/ __ |/  ___/
    \___ \ |  | \  ___/|  | \(  <_> |  / /_/ |\___ \
   /____  >|__|  \___  |__|   \____/|__\____ /____  >
        \/           \/                     \/    \/

Running "steroids-make-fresh" task

Running "steroids-check-project" task

Running "steroids-check-project-bower-dependencies" task
Project has bower dependencies installed... OK

Running "steroids-check-project-xml:www" (steroids-check-project-xml) task
Project has valid XML configuration files... OK

Running "steroids-clean-dist" task

Running "clean:dist" (clean) task
>> 1 path cleaned.

Running "steroids-copy-www" task

Running "copy:www" (copy) task


Running "steroids-compile-coffee" task

Running "coffee:compile_www" (coffee) task
>> 0 files created.

Running "steroids-copy-components" task

Running "copy:components" (copy) task
Created 43 directories, copied 272 files

Running "steroids-configure" task
No file found at www/config.xml, skipping.

Running "steroids-module-copy-assets:app" (steroids-module-copy-assets) task

Running "steroids-module-compile-views:app" (steroids-module-compile-views) task

Running "steroids-module-compile-scripts" task

Running "steroids-module-compile-coffeescript" task

Running "coffee:modules" (coffee) task
>> 0 files created.

Running "steroids-module-copy-javascript" task

Running "copy:modules" (copy) task
Copied 23 files

Running "steroids-module-concat-javascript:modules" (steroids-module-concat-javascript) task

Running "concat:module-admin" (concat) task
File dist/app/admin.js created.

Running "concat:module-amity" (concat) task
File dist/app/amity.js created.

Running "concat:module-common" (concat) task
File dist/app/common.js created.

Running "concat:module-drawer" (concat) task
File dist/app/drawer.js created.

Running "concat:module-login" (concat) task
File dist/app/login.js created.

Running "concat:module-secretary" (concat) task
File dist/app/secretary.js created.

Running "clean:tmp" (clean) task
>> 1 path cleaned.

Running "steroids-module-copy-default-native-styles" task

Running "copy:native" (copy) task
Copied 2 files

Running "steroids-module-compile-default-native-styles" task
Native SASS/SCSS files found, compiling...

Running "sass:native-app" (sass) task
Warning: spawn sass ENOENT Use --force to continue.

Aborted due to warnings.

I have walked through the steroids install tutorial, and all steps work fine. “steroids login” shows that I’m already logged in. My assumption is that High Sierra updated a dependency that I rely on, but I have no idea what it is… and I’m not an expert on node, nvm, etc. and I’m not sure where to start.

Thoughts?

Thanks in advance…

-j


Steroids Install Wizard Failure
#2

I tried to install steroids on a new install of High Sierra and I run into an issue

ENOENT: no such file or directory (...)/node_modules/.abbrev

Tried to npm cache clean and npm cache verify but still same issue


#3

Hi, Jeremy

Judging by the line > "Warning: spawn sass ENOENT Use --force to continue."
It appears that the sass was not found, probably due to an error in npm install or any other environment issue.
This issue: https://github.com/sass/node-sass/issues/2234 reports a problem with the node sass just eight days after your post.
And that one is related a sass issue specifically related to the Mac OS High Sierra: https://github.com/sass/sass/issues/2381
I think you should try the proposals of the last link
I’m using the High Sierra too, but steroids is working just fine…


#4

Hi, David1

Check your node version, try to update and repeat the steroids install proccess.
If you’re already using the node’s latest version, you can try to clean the node_modules folders manually
Try to check any warnings during the npm install command, specially anything with the words “permission” or “ENOENT” it could give you a hint of what to do next …


#5

Many thanks! I’ve gotten by so far by Time Machine-ing myself back to pre-High Sierra, and ignoring Apple’s (insistent) requests for me to upgrade again. We’re careening towards a release at the moment, but I’ll flag this for a retry. I appreciate the response!