Install Error by 'sudo npm install steroids@^4 -g'


#1

npm WARN deprecated wrench@1.5.4: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra) for any operations you were using wrench for. Thanks for all the usage over the years.
npm WARN deprecated graceful-fs@2.0.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use ‘npm ls graceful-fs’ to find it in the tree.
npm WARN deprecated node-uuid@1.4.7: use uuid module instead
npm WARN deprecated minimatch@0.3.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated lodash-node@2.4.1: This package is discontinued. Use lodash@^4.0.0.
npm WARN deprecated CSSselect@0.4.1: the module is now available as 'css-select’
npm WARN deprecated CSSwhat@0.4.7: the module is now available as 'css-what’
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use ‘npm ls graceful-fs’ to find it in the tree.
npm WARN lifecycle steroids@4.1.27~preinstall: cannot run in wd %s %s (wd=%s) steroids@4.1.27 node ./bin/preinstall.js || nodejs ./bin/preinstall.js /usr/local/lib/node_modules/.staging/steroids-c406b872
/usr/local/bin/steroids -> /usr/local/lib/node_modules/steroids/bin/steroids
/usr/local/lib
└─┬ steroids@4.1.27
└── UNMET PEER DEPENDENCY yo@1.8.1 || >=1.8.3

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@^0.3.1 (node_modules/steroids/node_modules/chokidar/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@0.3.8: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“linux”,“arch”:“x64”})
npm WARN generator-steroids@1.0.22 requires a peer of yo@1.8.1 || >=1.8.3 but none was installed.

Can any body help to fixed pls?


#2

Daniel I’m having a similar issue after having to reinstall new versions of node and steroids - have you found any solution?

Thanks!


#3

I fixed it by using a suggestion from another generator issue:

npm install -g yo steroids

using that command - everything worked!