How i can set cordova plugin version in build settings


#1

Please tell me, how i need to set in build for use this release of in-app purchase plugin https://github.com/j3k0/cordova-plugin-purchase/tree/v3.4.1

I’v try to set like cordova plugin add style https://github.com/j3k0/cordova-plugin-purchase.git@3.4.1 - but get error


#2

Use the syntax https://github.com/j3k0/cordova-plugin-purchase#v3.4.1


#3

Does this still work? I can’t get it working. Says:

“Adding plugin from: https://github.com/mapsplugin/cordova-plugin-googlemaps#v1.2.1
Failed to fetch package information for plugin.http.request”

The same goes with when adding ‘.git’ to the end:

“Adding plugin from: https://github.com/mapsplugin/cordova-plugin-googlemaps.git#v1.2.1
Failed to fetch package information for plugin.http.request”


#4

if its failing , verify that the cordova version requirement for plugin you want to use.
we been stuck with old version of cordova for a while and with no chance of an upgrade from appgyver until this is open sourced. Sad right?


#5

At least according to plugin.xml with the tag "#v1.2.1 it should be working. If it wasn’t, then the error message would be about incompatible version. Example:

Adding plugin from: https://github.com/mapsplugin/cordova-plugin-googlemaps.git
Plugin doesn’t support this project’s cordova-android version. cordova-android: 3.5.1, failed version requirement: >=5.1.0

The problem might be with the git repository or something. Or maybe I’m writing the tag wrong.