Application launch URL is not immediately available


#1

Hi, I need to add very basic functionality of deep linking (Custom Uri Scheme) in my app. I approached built in Appgyver Supersonic custom scheme, the urls working fine to launch the app from other apps, but failed to receive the launch URLs in the app.

Thanks in advance.


#2

I’m also facing the same issue. Let me know if you stumble upon a solution.

Here is my thread Supersonic.app.getLaunchURL() always returns null (Android)


#3

Can you post code? As I said in @Bilal_S’s post I have got this working on iOS (not tested on Android).


#4

I can confirm that launch URL is broken on Android. iOS works fine.

I tried everything that is suggested in various threads and support posts but nothing worked for Android (tested with 4.1.0 and up).

If anybody has a working plugin for e.g. branch or other deep linking solutions that would be fantastic. I tried a bunch but they all break now with Appgyver being stuck on Cordova 3.5. I’ll invest some time and try to port over the Branch.io plugin and will post it if something becomes available.

On a tangent - it is really high time Appgyver gets their s*** together and starts patching basic features like deep linking in their product.